Scheduled Maintenance. Certain Functions May Be Affected
Incident Report for Too Lost
Resolved
This incident has been resolved.
Posted Aug 02, 2022 - 12:41 EDT
Monitoring
Although downtime of certain functions is still applicable, we are resolving these issues and finalizing the new update shortly.
Posted Aug 01, 2022 - 01:04 EDT
Investigating
We are currently updating our web application. We expect to be finished rolling out these updates at July 30th, 2022 at 2:00pm EST.

You may experience outage of certain functionality including Stripe Connection, Payout Preferences, Account Detail Modifications, etc.

We appreciate your patience and cooperation, and we will keep you updated on our progress.
Posted Jul 30, 2022 - 01:06 EDT
This incident affected: Notification Emails, Account Email Validation, Subscription Payments, Checkout, and Web Servers.