Amazon AWS Server Outage - Reported Incident
Incident Report for Too Lost
Resolved
This incident has been resolved.
Posted Aug 22, 2023 - 12:23 EDT
Update
Servers have been restarted
Posted Aug 22, 2023 - 12:21 EDT
Update
Amazon has resolved this issue, and servers are back up / normal performance was restored
Posted Aug 22, 2023 - 12:20 EDT
Investigating
Amazon AWS US-EAST Servers are experiencing performance issues. We are currently investigating the issue. Impacted features include Uploader, Priority Pitch, Generate Graphics, Transfer In, Bulk Import and others.
Posted Aug 22, 2023 - 12:08 EDT
This incident affected: Too Lost (Main Site) and Web Servers.